Talkroute Status logo

Incident

Web Applications Outage

Closed | Jul 17, 2020 | 18:58 GMT-05:00

We have confirmed this outage was caused by Cloudflare. This is the second major outage Cloudflare has had the past year. We are in the process of moving all Talkroute operations away from Cloudflare. This issue is now fully resolved.

Investigating | Jul 17, 2020 | 16:52 GMT-05:00

All services appear to be operational at this time. We're going to investigate this issue fully and post an update on our findings on this incident.

Investigating | Jul 17, 2020 | 16:41 GMT-05:00

We have experienced a major outage to all of our webapps that we are investigating. Services seem to be operational at this time, but we're still investigating this incident. More updates to follow shortly. We believe this may be caused by one of our vendors (Cloudflare).