Talkroute Status logo

Incident

Issues with Phone Calls and Call History

Closed | Jun 06, 2019 | 13:54 GMT-05:00

After monitoring, we have determined this incident is fully resolved. If you are still having problems, please visit https://support.talkroute.com/ for further assistance. We sincerely apologize for the inconvenience this has caused!

Monitoring | Jun 06, 2019 | 11:11 GMT-05:00

Our peering carrier has resolved this issue. There was an equipment failure that was causing calls to fail periodically. This has been resolved. We're going to keep this event open for monitoring. If you are still having problems, please visit https://support.talkroute.com/ for further assistance. We sincerely apologize for the inconvenience this has caused!

Identified | Jun 06, 2019 | 10:30 GMT-05:00

We are still actively working with our peering carrier to resolve this issue. We do not have an estimated restoration time at this time. We sincerely apologize for this inconvenience.

Identified | Jun 06, 2019 | 10:03 GMT-05:00

We are still working with our carrier to try to resolve this issue.

Identified | Jun 06, 2019 | 08:29 GMT-05:00

We have further identified this issue with a specific peering carrier. We are actively working with them to resolve this issue. Only certain phone numbers are affected by this outage.

Open | Jun 06, 2019 | 08:03 GMT-05:00

We are seeing an issue with some calls not getting through and call history not updating. We are investigating this issue.