Talkroute Status logo

Incident

Voice Calls are Down for Some Numbers

Closed | Jan 08, 2020 | 12:12 GMT-06:00

Closing our this incident as it's fully resolved.

Monitoring | Jan 06, 2020 | 08:36 GMT-06:00

We have worked with our carrier and voice services have now been restored. We're monitoring this issue for 24 hours.

Investigating | Jan 06, 2020 | 07:53 GMT-06:00

A select number of phone numbers are not working when you dial them. We are engaged with our upstream carrier for those numbers and we are looking into the issue.