Talkroute Status logo

Incident

Desktop/Web Applications Outage

Closed | Jun 17, 2021 | 10:26 GMT-05:00

Closing this case

Resolved | Jun 01, 2021 | 17:09 GMT-05:00

This issue has been resolved

Monitoring | Jun 01, 2021 | 09:41 GMT-05:00

We have identified and fixed the source of the disconnects with the desktop and Web apps. All services appear to be operational at this time and we will continue to monitor the situation.