Talkroute Status logo

Incident

Partial Voice and Messaging Outage

Closed | Oct 04, 2021 | 15:55 GMT-05:00

We have observed network stability with the affected carrier for 5 days. We are going to declare this incident resolved. We have re-routed major portions of our network to avoid using this carrier and are going to continue so as time allows. We will notify everyone again if this issue happens again.

Monitoring | Sep 29, 2021 | 19:24 GMT-05:00

We are seeing a restoration of service at this time. We are keeping this incident open until we confirm that this DDoS event has ended.

Monitoring | Sep 29, 2021 | 18:20 GMT-05:00

We are currently observing that our voice interconnection with the underlying carrier that is affected by the DDoS attack has gone offline. We are currently in the process of re-routing our voice traffic from this carrier while the national carrier outage continues.

Monitoring | Sep 27, 2021 | 18:41 GMT-05:00

As of now, the troubled underlying carrier has restored service. It appears the DDoS attack is still occurring, but the carrier has successfully mitigated the attack. Plans to move affected numbers to a different underlying carrier are still in place. We are continuing the monitor this situation closely.

Resolution in progress | Sep 27, 2021 | 13:32 GMT-05:00

Over the past 3 days, a major underlying phone carrier has been under a DDoS attack.

This DDoS attack has successfully taken their network offline. Due to this, Inbound Voice calling for a subset of Talkroute phone numbers has been impacted. This incident is also impacting a number of other service providers, similar to Talkroute, that utilize this underlying carrier for service within their network.
Due to the length and the scale of this DDoS attack, we have decided to start the process of moving these numbers to one of our other underlying carriers. We are hopeful that service will be restored in the meantime but this is a necessary step that we will be taking in order to guarantee restored service to these phone numbers.

This transfer process is going to take time, but we're doing everything possible to expedite this process. We understand how frustrating this situation is and appreciate your continued patience. We want to assure you that we are doing everything in our power to bring the impacted numbers back online.

Resolution in progress | Sep 27, 2021 | 09:18 GMT-05:00

Our partnering carrier has been under an ongoing DDoS attack since Saturday. This DDoS attack has taken down our voice circuits with them. We have begun the process of moving voice traffic away from this carrier and onto partnering carrier networks. We have all resources available on this issue.

Monitoring | Sep 25, 2021 | 17:15 GMT-05:00

All services appear to be operating normally. We're going to continue monitoring this situation very closely.

Resolution in progress | Sep 25, 2021 | 16:17 GMT-05:00

The affected voice and text messaging systems reliability continues to improve. We are actively monitoring this situation until we can confirm this incident is over.

Resolution in progress | Sep 25, 2021 | 15:37 GMT-05:00

We're seeing some resolution on this matter. Voice calls and text messages are starting to come through. We are still actively monitoring this situation.

Identified | Sep 25, 2021 | 14:37 GMT-05:00

One of our partnering carriers is experiencing an outage. Some phone numbers are experiencing trouble with phone calls and text messages. All appropriate teams are engaged on this matter we hope to see resolution shortly.